Showing results for 
Search instead for 
Did you mean: 


Supporting Actor TV
1 0 0

Struggling with UPC TV Box

I received Home Giga last week and finally installed it last Monday. ConnectBox works fine, for now at least, has no problems with it. But with TV Box I'm struggling to fix it since yesterday. When I installed it on Monday, it works fine, even without coax cable - it didn't let me see TV channels, but I had access to apps (Netflix, YouTube, SkySport...) and movies for rent. But yesterday we wanted to watch a movie on Netflix, switched the box on and after Welcome screen we just had a black screen. We switched it off and on with the button from behind, and then it worked. And today all day I tried to switch it on, and it doesn't work, not even connected to the main screen with apps and everything. Unfortunately, you don't have English speaking telephone advisors, and getting through Messenger to your helpline also didn't help a lot. So, I don't know what to do. I've already moved TV to another room, so I can connect coax cable, because at your helpline I was told that the box wouldn't work without coax connection, even apps (even though they worked first couple of days). Right now, I have reconnected it again as written in the instruction, with LAN connection. But all I get is the Welcome screen and then everything is black again. I probably need a technician to help with this, but I can't find a link to set a date, and if I call to your telephone advisors, I'm afraid my French skills won't be sufficient. 

544 204 44

Re: Struggling with UPC TV Box

Hi @Kseniia


Welcome in our community.


First of all, we are sorry that you had issues to get your TV experience started. Please make sure that you don't start double entries in the community. This would complicate your chances to get help. 


Concerning your issue. Please make sure that you connect your UPC TV Box directly to the cable socket and also use a LAN cable to connect with the Connect Box for Internet. Afterwards start over the installation process. It could take a couple of minutes. Just repeat the steps again. If it does not help. Please try again to get in touch with our technical service. They will connect you to a english speaking agent. Thank you for your understanding. 


I am sure you will also get help from our community.


@All: Are there users who had the same issue?


Best regards,